Back to overview
Degraded

Dashboard and billing metrics delayed

May 20 at 01:26pm UTC
Affected services
Clerk Dashboard
Clerk Billing

Resolved
May 20 at 03:01pm UTC

Clerk's systems have recovered from the previously reported delay.

Created
May 20 at 01:26pm UTC

There is a backup of pubsub messages not making it into ClickHouse which is causing some Clerk services to be impacted by stale data.