Back to overview
Downtime
Dashboard, frontend, and backend APIs are unavailable
May 08 at 05:02pm UTC
Affected services
Frontend API
Backend API
Clerk Dashboard
Development Environment
Resolved
May 08 at 05:11pm UTC
All services (Frontend API, Backend API, an Dashboard) are again operational. We are continuing efforts to diagnose the root cause.
Affected services
Frontend API
Clerk Dashboard
Backend API
Development Environment
Created
May 08 at 05:02pm UTC
The Frontend API, Backend API, and Dashboard are unavailable. We are actively investigating and will update again promptly when we know more.
Affected services
Frontend API
Clerk Dashboard
Backend API
Development Environment