Resolved
There was a service degradation on our caching layer that affected the latency of our APIs. The caching layer is back to normal and latency dropped to normal levels.
Investigating
There is increased latency on our APIs. We are investigating.