Resolved
The incident has resolved.
Monitoring
Revert has been deployed and systems have stabilized. We will continue to monitor.
Identified
Beginning 1:44am UTC: A subset of customers using satellite domains began experiencing failures. The issue has been identified and is being reverted.