Resolved
The root cause was a DDoS attack against our infrastructure. It has been fully mitigated and all systems are back to normal.
Monitoring
Performance has stabilized after our earlier mitigations. We're continuing to monitor closely and will give a final update once we've confirmed full recovery.
Monitoring
We've found the source of the performance issue and applied mitigations. Systems are stabilizing and we're still monitoring closely. We'll update again once we've confirmed full recovery.
Investigating
We're investigating intermittent errors affecting API requests. Some requests may experience elevated latency or failures.