Clerk

DNS Outage causing critical services to go down
Affected components
Updates

Write-up published

Read our write-up of this incident at https://clerk.com/blog/2026-02-10-dns-outage-postmortem

Resolved

A post-mortem has been published on Clerk's blog. See the write up above for details.

Fri, Feb 13, 2026, 06:17 PM

Resolved

Our DNS provider has recovered their services and everything is back online. We are so sorry for the issues and appreciate your patience. A full postmortem will follow, including details on mitigations we will put in place to prevent issues like this in the future.

Tue, Feb 10, 2026, 07:43 PM(2 days earlier)

Monitoring

We're seeing that most services have recovered, we are still monitoring and will post another update on full recovery.

Tue, Feb 10, 2026, 07:37 PM

Investigating

We have restored DNS resolution for `accounts.clerk.services` and `frontend-api.clerk.services` - no need to update DNS records anymore. If you previously updated your DNS records, you can change them back (but if you leave them as they are, it will be fine, nothing will go down).

Email/SMS services continue to be impacted by the DNS provider outage.

Tue, Feb 10, 2026, 06:45 PM(51 minutes earlier)

Investigating

For fastest manual recovery, we still recommend updating your own DNS records manually:

CNAME `accounts.<yourdomain>` -> `worker.clerkprod-cloudflare.net`
CNAME `clerk.<yourdomain>` -> `worker.clerkprod-cloudflare.net`

We also have updated our nameservers to resolve to a fallback DNS provider, though we are observing that propagation is still underway.

Once resolution occurs through either approach, most of Clerk's service will recover, but email-based authentication will still encounter validation issues.

We are in the process of updating our fallback DNS provider with the appropriate email records.

Tue, Feb 10, 2026, 06:28 PM(17 minutes earlier)

Investigating

In order to mitigate this issue temporarily, we recommend updating your DNS settings as such:

CNAME `accounts.<yourdomain>` -> `worker.clerkprod-cloudflare.net`

CNAME `clerk.<yourdomain>` -> `worker.clerkprod-cloudflare.net`

Tue, Feb 10, 2026, 05:54 PM(33 minutes earlier)

Investigating

Clerk services are unable to be resolved via DNS due to a provider outage, cached DNS may be keeping things up temporarily

Tue, Feb 10, 2026, 05:50 PM

Investigating

Our DNS provider is is having an outage, which has caused most of our major services not to resolve. We're currently investigating actively.

Tue, Feb 10, 2026, 05:35 PM(15 minutes earlier)