Clerk

Go Live is degraded due to SSL issuance delays
Resolved·Degraded performance

Our upstream provider has resolved their incident. All SSL issuance operations have returned to normal, and we are no longer observing delays or failures.

Tue, Dec 2, 2025, 03:51 PM
(1 day ago)
·
Affected components
Updates

Resolved

Our upstream provider has resolved their incident. All SSL issuance operations have returned to normal, and we are no longer observing delays or failures.

Tue, Dec 2, 2025, 03:51 PM

Identified

Our upstream provider has identified the issue and is implementing a fix

Tue, Dec 2, 2025, 03:30 PM(21 minutes earlier)

Investigating

Our SSL issuance flow is temporarily delayed due to an upstream issue with our certificate provider. This only affects newly added domains. Existing domains and certificates continue to function normally. We'll provide updates as the provider resolves the issue.

Tue, Dec 2, 2025, 03:20 PM(10 minutes earlier)