Clerk

Clerk Dashboard is down
Resolved·Full outage

We have been fully operational for a few hours now. Our providers are also reporting healthy.

Mon, Oct 20, 2025, 02:07 PM
(2 weeks ago)
·
Affected components
Updates

Resolved

We have been fully operational for a few hours now. Our providers are also reporting healthy.

Mon, Oct 20, 2025, 02:07 PM

Monitoring

Clerk Dashboard is up and fully functional. We will keep monitoring the situation.

Mon, Oct 20, 2025, 08:23 AM(5 hours earlier)

Identified

Clerk Dashboard is impacted by a provider issue. We are monitoring the situation.

Mon, Oct 20, 2025, 08:03 AM(20 minutes earlier)