Clerk

Email deliverability issues for development instances
Resolved·Partial outage

The team identified the root cause with the downstream email provider and has implemented a fix. Email delivery for development instances should now be working as expected.

Tue, Jul 22, 2025, 04:12 PM
(1 week ago)
·
Affected components
Email Delivery
Updates

Resolved

The team identified the root cause with the downstream email provider and has implemented a fix. Email delivery for development instances should now be working as expected.

Tue, Jul 22, 2025, 04:12 PM

Identified

We have identified the root cause of the issue and are in contact with our Email Provider to resolve it as soon as possible

Tue, Jul 22, 2025, 12:40 PM(3 hours earlier)

Investigating

We’re currently investigating email deliverability issues for development instances.

Tue, Jul 22, 2025, 11:01 AM(1 hour earlier)