Clerk

Elevated latency
Resolved·Degraded performance

We've resolved the incident and we'll continue to monitor.

Sun, Jul 20, 2025, 06:18 PM
(21 hours ago)
·
Affected components
Frontend API
Backend API
Clerk Dashboard
Updates

Resolved

We've resolved the incident and we'll continue to monitor.

Sun, Jul 20, 2025, 06:18 PM

Monitoring

We've identified the issue and have implemented a fix.

Sun, Jul 20, 2025, 06:09 PM

Investigating

We're continuing to investigate and we'll share an update as soon as we know more.

Sun, Jul 20, 2025, 05:38 PM(30 minutes earlier)

Investigating

We are continuing the investigate the root cause.

Sun, Jul 20, 2025, 04:06 PM(1 hour earlier)

Investigating

We're still investigating elevated latency.

Sun, Jul 20, 2025, 02:50 PM(1 hour earlier)

Investigating

We're investigating elevated latency.

Sun, Jul 20, 2025, 02:40 PM(10 minutes earlier)