Sendgrid has reported that the email sending delays are resolved and emails are now sending as expected. More information on their status page here: https://status.sendgrid.com/
Resolved
Sendgrid has reported that the email sending delays are resolved and emails are now sending as expected. More information on their status page here: https://status.sendgrid.com/
Identified
Our email provider, Sendgrid, has an incident that is causing delays in email delivery. More details can be seen here: https://status.sendgrid.com/
We will update as soon as we have more information.