Clerk

System Downtime
Resolved·Full outage

All systems returned to normal at 7:01 UTC. We will followup with an incident report as soon as possible.

Thu, Jun 26, 2025, 07:25 AM
(1 day ago)
·
Affected components
Frontend API
Backend API
Clerk Dashboard
Clerk Billing
SMS Delivery
Email Delivery
Webhooks
Updates

Resolved

All systems returned to normal at 7:01 UTC. We will followup with an incident report as soon as possible.

Thu, Jun 26, 2025, 07:25 AM

Monitoring

We are continuing to monitor service restoration.

Thu, Jun 26, 2025, 07:13 AM(12 minutes earlier)

Monitoring

Our systems have started to recover and access is being restored

Thu, Jun 26, 2025, 07:07 AM

Investigating

We are continuing to investigate.

Thu, Jun 26, 2025, 06:49 AM(18 minutes earlier)

Investigating

We are investigating reports of Clerk services being down.

Thu, Jun 26, 2025, 06:29 AM(20 minutes earlier)