Back to overview
Degraded
Certain functionality of the Clerk Dashboard is not working
Apr 16 at 07:51pm UTC
Affected services
Clerk Dashboard
Resolved
Apr 16 at 08:37pm UTC
Dashboard functionality is fully restored
Affected services
Clerk Dashboard
Updated
Apr 16 at 08:33pm UTC
Dashboard functionality is restored. Metrics and fraud data are delayed but recovering.
Affected services
Clerk Dashboard
Created
Apr 16 at 07:51pm UTC
Some features of the Clerk Dashboard, including statistics and some elements of the billing UI, are not working.
Affected services
Clerk Dashboard