Back to overview
Downtime

Clerk Dashboard Partial Outage

Apr 04 at 09:27pm UTC
Affected services
Clerk Dashboard

Resolved
Apr 04 at 09:39pm UTC

Issues on the dashboard have been resolved. It appears as if an upstream provider's downtime caused an error in our dashboard, which has now been resolved. We're looking into this further and will update the status as soon as we have more information.

Created
Apr 04 at 09:27pm UTC

We have noticed that Clerk's dashboard is down for a large number of users. We're looking into this actively and aiming to have it fixed as quickly as possible. We have not seen any impact on Clerk applications, only the dashboard.