Back to overview
Downtime

Configuration Issue Caused 27-Minute Downtime

Feb 06 at 09:48pm UTC
Affected services
Frontend API

Resolved
Feb 06 at 10:14pm UTC

At approximately Feb 6, 2025 9:43 PM UTC we performed a configuration update to upgrade ~3700 Clerk instances with a legacy setting. Unfortunately, this update contained an error. As a result, application code ran into an error on a majority of API requests, causing downtime for the impacted instances.

We identified and addressed the root cause, with an update that ran on Feb 6, 2025, at 10:06 PM UTC. We have observed no further occurrences of this error, and performance of Clerk systems appear to be back to normal. We will continue to monitor our systems closely.

Created
Feb 06 at 09:48pm UTC

We have confirmed that a large number of Clerk applications are experiencing downtime and are actively investigating.