Back to overview
Degraded
Un-intended breaking change to JSON serialization
Dec 12 at 07:26pm UTC
Affected services
Frontend API
Resolved
Dec 13 at 04:40pm UTC
The JSON.stringify issue has been resolved, sorry for the inconvenience.
Affected services
Frontend API
Created
Dec 12 at 07:26pm UTC
A change was rolled out to Clerk's frontend SDKs that caused the results of calling JSON.stringify
on Clerk's core resource objects from the frontend to return snake_case keys instead of camelCase keys (for example, within a client component). If your code was relying on the format for the keys of stringified Clerk resource objects, this was a breaking change.
While we marked the affected service as the Frontend API, the API itself was not impacted, only SDKs.
Affected services
Frontend API