Back to overview
Degraded
Emails delayed
Oct 25 at 04:55pm UTC
Affected services
Frontend API
Backend API
Resolved
Oct 25 at 08:58pm UTC
Sendgrid is no longer reporting issues, and emails are now being delivered in an appropriate amount of time.
Affected services
Frontend API
Backend API
Created
Oct 25 at 04:55pm UTC
Emails sent by Clerk are subject to a substantial delay. We have been notified of a widespread problem with our 3rd party outgoing email provider, and we are seeking a resolution.
Affected services
Frontend API
Backend API