Back to overview
Degraded
Dashboard Outage
Jun 07 at 10:52pm UTC
Affected services
Clerk Dashboard
Resolved
Jun 07 at 11:46pm UTC
Clerk Engineers identified the key that was causing the issue and updated our services which reference it. All services are functioning.
Affected services
Clerk Dashboard
Created
Jun 07 at 10:52pm UTC
At 22:52 UTC The Clerk.com Dashboard was inaccessible to a subset of our users. This lasted for about an hour and has been resolved. This was caused by a cache interacting with a key rotation. Service has been restored to all dashboard users.
Affected services
Clerk Dashboard