Performance Degraded
Resolved
Apr 25 at 01:47pm UTC
Systems are operating as expected now. We have placed a change in place to prevent the original performance degradation scenario from recurring and continue to monitor closely.
Affected services
Frontend API
Clerk Dashboard
Backend API
Updated
Apr 25 at 01:35pm UTC
We have identified the source of the degradation and have stopped it from causing issues. Performance is improving as the system recovers.
Affected services
Frontend API
Clerk Dashboard
Backend API
Created
Apr 25 at 01:20pm UTC
Since 1:00PM UTC we have observed API Calls are performing more slowly than normal, a small percentage are failing and causing errors. We are actively investigating and working to restore performance.
Affected services
Frontend API
Clerk Dashboard
Backend API