Back to overview
Degraded
Degraded performance on Dashboard and Frontend API
Apr 09 at 03:03pm UTC
Affected services
Frontend API
Backend API
Clerk Dashboard
Resolved
Apr 09 at 03:21pm UTC
We've observed performance as restored. We'll continue to monitor
Affected services
Frontend API
Clerk Dashboard
Backend API
Updated
Apr 09 at 03:15pm UTC
The issue has been identified and performance seems to be recovering. We'll continue to monitor performance
Affected services
Frontend API
Clerk Dashboard
Backend API
Created
Apr 09 at 03:03pm UTC
We have seen increased latency on the Dashboard as well as our Frontend API. We are actively investigating now.
Affected services
Frontend API
Clerk Dashboard
Backend API