Back to overview
Degraded

Degraded performance

Jun 23 at 04:35pm UTC
Affected services
Frontend API
Backend API
Clerk Dashboard

Resolved
Jun 23 at 05:45pm UTC

We identified and resolved the issue.

Created
Jun 23 at 04:35pm UTC

Requests across all Clerk APIs (FAPI, BAPI, DAPI) were slow or failing with 5XX errors due to high CPU usage in the primary Postgres Database.

The incident lasted about an hour.

During the incident about 10-15% of requests across all APIs were failing, with the rest being slow