Between 21:21 and 21:56 UTC on June 9, 2026, a portion of requests to our Analytics service failed and Dashboard charts may have failed to load. The cause was a database connection that had been silently closed upstream but was still being reused by our connection pool. We resolved the issue at 21:56 UTC. No data was lost. To prevent recurrence, we are rolling out a change to detect and self-heal from such failures. We apologize for the disruption
Resolved
Between 21:21 and 21:56 UTC on June 9, 2026, a portion of requests to our Analytics service failed and Dashboard charts may have failed to load. The cause was a database connection that had been silently closed upstream but was still being reused by our connection pool. We resolved the issue at 21:56 UTC. No data was lost. To prevent recurrence, we are rolling out a change to detect and self-heal from such failures. We apologize for the disruption
Monitoring
We've mitigated a connection issue with the Analytics API and are now monitoring.
Investigating
Endpoints that use analytics (such as dashboard charts) are encountering timeouts. We are investigating.