Monitoring
Our upstream provider has implemented a fix for domain provisioning. We are seeing signs of recovery and are continuing to monitor the situation.
Investigating
There is an ongoing issue with one of our upstream providers which is impacting the provisioning of domains.