Resolved
The issue has been resolved.
Monitoring
We have deployed a mitigation and are observing.
Investigating
Some customers are encountering an issue where the root route at the Accounts Portal is returning 404 and not redirecting to the appropriate page.